
UNIT – 3:USING IMAGE PROCESSING TOOLS 
 Photoshop workshop 
Adobe Photoshop is the predominant photo editing and manipulation software on the market. Its uses range from full featured editing of large batches of
photos to creating intricate digital paintings and drawings that mimic those done by hand.

Image editing tools

 Selection and move Tools

Adobe Photoshop also offers a number of selection tools:Rectangular marquee, Elliptical marquee, Lasso, Polygonal Lasso, Magnetic Lasso, Magic
Wand.

The Rectangular marquee and Elliptical marquee tools are hidden in the Toolbox under one and the same icon. The icon on the Toolbox displays the
last tool used. To open the floating menu right-click on the arrow in the lower right corner of the displayed icon.

 Rectangular marquee

This tool selects rectangular and square areas.
To select a rectangular area, you should:

Step 1. Activate the Rectangular marquee tool by clicking on the icon , or (if the Rectangular marquee was not the last tool applied) select it from the
floating window.

Step 2. Bring the mouse cursor to the point of the image where the corner of an imaginary rectangle should be and press the left mouse button.

Step 3. Keeping the left button pressed, move the cursor diagonally to the opposite corner and release the button.

To select a square area of the image, make a selection keeping the Shift key pressed. Take into account that if you already have a selected area
the new selection will be added to the previous one. To avoid it you should press the Shift key only when you start selecting a new area. 

 Elliptical marquee

This tool selects ellipses and circles.
To select an elliptical area, you should:

Step 1. Select the Elliptical marquee tool from the Toolbox by clicking on the icon  , or (if the Elliptical marquee was not the last tool applied) select it
from the floating window.

Step 2. Bring the mouse cursor to the point of the image where the corner of an imaginary rectangle with an inscribed ellipse should be and press the left
button.

Step 3. Keeping the left button pressed, move the cursor diagonally to the opposite corner and release the button.

To select a circular area of the image make a selection keeping the Shift key pressed. Take into account that if you already have a selected area
the new selection will be added to the previous one. To avoid it you should press the Shift key only when you start selecting a new area.

If you keep the Alt (Option in Mac) key pressed when selecting an elliptical or a rectangular area, the selection is generated from the center to
borders, not from one corner to another.

 
The Lasso, Polygonal Lasso, Magnetic Lasso tools are hidden in the Toolbox under one and the same icon. The icon on the Toolbox displays the last tool
selected. To open the floating menu right-click on the arrow in the lower right corner of the displayed icon.

 Lasso

The tool allows creating freehand selections.
To make a freehand selection you should:

Step 1. Select the Lasso tool from the Toolbox by left-clicking on the icon , or (if Lasso was not the last tool applied) select it from the floating
window.

Step 2. Bring the mouse cursor to the object that must be selected and outline it keeping the left button pressed.

Polygonal Lasso

The tool makes freehand selections, but its contour is made up of straight segments.

To make a selection you should:
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Step 1. Select the Polygonal Lasso tool from the Toolbox by clicking on the icon , or (if Polygonal Lasso was not the last tool applied) select it from
the floating window.

Step 2. Bring the cursor to any point near the object to be outlined and press the left mouse button - it'll be the first point of the contour.

Step 3. Move the cursor to the next point of the contour not far from the first one and left-click it again. The program will automatically draw a straight
line between the two points.

Step 4. Keep putting points in this way until the whole object is outlined and close the contour.

 Magnetic Lasso

This tool makes a freehand selection.

When you use Magnetic Lasso, you do not need to follow the contour of the object precisely. If the object stands out against the background the
border of the selected area will be traced automatically as you move the cursor along the object.

To select an area using Magnetic lasso you should:

Step 1. Select the Magnetic Lasso tool from the Toolbox by clicking on the icon , or (if Magnetic Lasso was not the last tool applied) select it from the
floating window.

Step 2. Bring the mouse cursor to the border of the object that should be selected.

Step 3. Press the left button and start dragging the cursor along the object. Pay attention to fastening points that appear as you outline the object and when
you make a click. If a fastening point is irrelevant you can remove it by pressing the Delete key and return to the previous fastening point to continue
outlining the object.

Step 4. Close the contour, that is join the first fastening point with the last one by bringing the cursor to the first point or by making a double-click.

 Magic Wand

This tool selects a consistently colored area. You can set Tolerance in the Options palette of the Magic Wand tool. The higher is the value, the
more colors will  fall  into the selected area.  The Tolerance value ranges from 0 to 255.  At Tolerance equal to 0 the selected area will  be
represented only by one color, at Tolerance equal to 255 - all colors of the image will be selected, that is the whole image.

To select a consistently colored area, you should:

Step 1. Select the Magic Wand tool in the Toolbox by clicking the icon .

Step 2. Bring the cursor to the pixel of the image that must be included into the selection and left-click it. As a result an outline appears around the pixel. It
includes colors of the image similar to the color of the selected pixel according to the specified Tolerance value.
 
These selection tools are efficient due to the flexibility of their usage: you can add to, subtract from or intersect a selection.
To add an area to the previous selection you should press the Shift key before you use a selection tool and, keeping it pressed, make a new selection.

To subtract an area from the previous selection you should press the Alt (Option in Mac) key before you use a selection tool and, keeping it pressed, make
a new selection.

If you press Shift and Alt (Shift and Option in Mac) keys simultaneously you obtain an intersection of the old and new selections.

Selection Shading
Whether you've made a selection with Photoshop tools or used a plugin you'd want your selection to look nice and smooth on a new background. This
happens when the edges of the object blend with the background colors. If the edges of the selected image were not softened or feathered during the
process of selection you may shade them in Photoshop.

All you have to do is:

 Step 1. In Adobe Photoshop have your selection loaded. Open Select menu and choose Feather.

 Step 2. In the opening dialogue window type in a number of pixels to be feathered (2-5 are usually enough).
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 Step 3. Now you can copy your selection, paste it into a new environment and evaluate the result.

No shading 5 px shading

15 px shading
50 px shading

 Moving an object in Adobe Photoshop

To move an object, we can either move the layer with the inserted object or select a layer fragment and move this immediate fragment.

Select the Move  tool from the Toolbar to move the layer or its fragment.

First of all, activate the layer with the inserted object and follow the instructions:

Step 1. If you want to move a fragment of the layer not the layer itself, you can select the necessary area using any selection tool.

Step 2. Select the Move tool from the Toolbar.

Step 3. Bring the cursor inside the selected fragment to move it or on any point of the layer to move the layer itself.

Step 4. Drag the object. For this purpose, press the left mouse button and keeping it pressed drag the mouse cursor.

 Transformation of objects in Adobe Photoshop photo editor

After an object is inserted in a new layer, we can use Layer transformation commands to transform the object. To transform the layer or the
selected fragment we can use one of the commands from the menu Edit - Transform. For example, the following commands: Scale, Rotate,
Skew, Distort, Perspective, rotate 180°, Rotate 90° CW, rotate 90° CCW, Flip Horizontal, Flip Vertical.

You can also use the command Free Transform from the Edit menu, which will help you to perform all transformations at one time. If you
select the command Edit – Free Transform, the layer or the selected fragment will be enclosed in a frame with eight markers, and in the Options
palette a number of parameters for adjustment will appear.

<="" div="" 

 Scale – to adjust the scale of the image within the area you should move one of the eight markers. To change the scale proportionally you should
drag the marker in the corner keeping the Shift key pressed. You can enter values for the W and H parameters in percentage from the original
size directly in the Options palette. For the size to be changed proportionally, you should activate the relation sign between the W and H
parameters.

Flip – to flip an image you should move one of the markers behind the opposite marker. For example, if you drag the left marker all the way to
the right side of the right marker, the image will flip horizontally. However, if all you want is to flip the image, you'd better use the commands
Flip Horizontal and Flip Vertical from the menu Edit – Transform.

Rotate – to rotate an image you should bring the cursor to the marker in the corner so that the cursor transforms in a two-side rounded arrow,
press the left mouse and keeping it pressed, drag the cursor. You can set the rotation angle in the Options palette using the Rotate parameter.

Skew – to skew an image you should drag the marker on the side, the upper and the lower marker keeping the  Ctrl key pressed (Command in
Mac). You can adjust the Skew transformation option in the Options palette setting the H and V parameters.

Distort – it is possible to distort an image by dragging a corner marker keeping the Ctrl key pressed (Cmd in Mac).
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Perspective –  to  create  a  perspective  you  should  drag  a  corner  marker  keeping  the Ctrl and Shift keys  pressed  (Cmd and Shift in  Mac).
If you want to drag two points at a time, you should drag a corner marker keeping the  Ctrl, Alt and Shift keys pressed (Cmd, Option and Shift in
Mac).

To confirm the transformation press, enter (Return in Mac) or double-click with the left mouse button inside the object. You can as well press the

button  in the Options palette.

  To cancel the transformation press Esc or the button  in the Options palette.

Cropping an Image in Adobe Photoshop

Cropping - This changes the number of pixels in an image by "cropping" away the pixels from the surrounding area.

In the photo editor Adobe Photoshop an image can be cropped with the Crop tool or the Crop command.

To crop an image with the Crop tool, follow these instructions:

Step 1. Choose the Crop tool  from the Tool Panel or press C.

Step 2. Bring the cursor to a point on the image, where a corner of the cropped image will be, and left-click the mouse.

Step 3. Moving the cursor diagonally, keep the left mouse button pressed.

Step 4. Release the left mouse button. A box will appear over the image with marked corners, indicating the area that will be preserved. This box
can be moved, resized, and rotated.

o To move the crop box, move the cursor completely inside the selected area, press the left mouse button, and while keeping the left
mouse button pressed, drag the box.

o To change the size of the selected area move the cursor to one of the corner markers, press the left mouse button and drag the marker.
If the cursor is dragged while pressing Shift, the size of the box will be changed proportionally.

o To rotate the crop box move the cursor to one of the corner markers and drag the cursor.

 Шаг 5. Press Enter (Return on Mac) or press the  button in the Options Panel to crop the image.

To close the crop box without cropping the image press Esc or press the  button in the Options Panel.

 To crop an image with the Crop command from the Photoshop menu, follow these steps:

 Step 1. Choose the Rectangular marquee tool from the Tool Panel.
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 Step 2. Select a rectangular area on the image Selection Tools in Adobe Photoshop).

 Step 3. Choose Crop from the Image menu.

Drawing Gradients in Photoshop

Creating A New Document

Let's start by creating a new Photoshop document. To do that, I'll go up to the File menu in the Menu Bar along the top of the screen and choose New:

Going to File > New.

This opens the New dialog box. For this tutorial, I'll set the Width of my document to 1200 pixels and the Height to 800 pixels. There's no particular
reason why I'm using this size, so if you're working along with me and have a different size in mind, feel free to use it. I'll leave the Resolution value set to
its default of 72 pixels/inch, and I'll make sure Background Contents is set to White. I'll click OK when I'm done to close out of the dialog box, at which
point a new white-filled document appears on the screen:

The New dialog box.

Selecting the Gradient Tool

Photoshop's Gradient Tool is found in the Tools panel along the left of the screen. I'll select it by clicking on its icon. You can also select the Gradient
Tool simply by pressing the letter G on your keyboard:

Selecting the Gradient Tool from the Tools panel.

The Gradient Picker

With the Gradient Tool selected, the next thing we need to do is choose a gradient, and there's a couple of ways we can do that. One is by opening
Photoshop's Gradient Picker; the other is by opening the larger Gradient Editor. The difference between the two is that the Gradient Picker simply
allows us to choose from ready-made preset gradients, while the Gradient Editor, as its name implies, is where we can edit and customize our own
gradients. 

When you just want to choose one of Photoshop's preset gradients, or one that you've previously created on your own and saved as a custom preset (again,
we'll learn how to do that in the next tutorial), click on the small arrow to the right of the gradient preview bar in the Options Bar. Make sure you click
on the arrow itself, not on the preview bar (clicking the preview bar will open the Gradient Editor and we don't want to go there just yet):

5

http://akvis.com/en/photoshop-tips/selection-tools.php


Multimedia Application

Clicking the arrow to open the Gradient Picker.

Clicking the arrow opens the Gradient Picker, with thumbnails of all the preset gradients we can choose from. To choose a gradient, click on its thumbnail,
then press Enter (Win)  / Return (Mac)  on your  keyboard,  or  click on any empty space in  the Options Bar, to  close the Gradient  Picker. You can
also double-click on the thumbnail, which will both select the gradient and close out of the Gradient Picker:

The Gradient Picker.

Loading More Gradients

By default, only a small number of preset gradients are available, but Photoshop includes other  gradient sets that we can choose from. All we need to do
is load them in. To do that, click on the gear icon in the upper right:

Clicking the gear icon in the Gradient Picker.

If you look in the bottom half of the menu that appears, you'll find the list of additional gradient sets, each based on a specific theme, like color harmonies,
metals, pastels, and more. If you're a photographer, the Neutral Density and Photographic Toning gradients are particularly useful:

The other gradient sets we can choose from.To load any of the sets, click on its name in the list. I clicked on the Photographic Toning
set. Photoshop will ask if you want to replace the current gradients with the new ones. If you click Append, rather than
replacing the original gradients, it will simply add the new ones below the originals. As we'll see in a moment, it's easy to
restore the originals, so I'll click OK to replace them with the Photographic Toning set:

Clicking OK to replace the original gradients with the new set.

And now, we see in the Gradient Picker that the original gradients have been replaced with the Photographic Toning gradients.

The original gradients have been replaced with the new set.

Restoring the Default Gradients

To keep us focused on the basics, we'll stick with the original default gradients for now. To restore them, click once again on the  gear icon in the Gradient
Picker:
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Clicking the gear icon.

Then choose Reset Gradients from the menu:

Choosing "Reset Gradients".

Photoshop will ask if you want to replace the current gradients with the defaults. Click OK:

Replacing the current gradients with the defaults.

And now, we're back to the originals:

The default gradients have been restored.

The Foreground To Background Gradient

Before we learn how to draw gradients,  let's  quickly look at  one gradient in particular -  the  Foreground to Backgroundgradient.  It's  the one that
Photoshop selects for us by default, but you can also select it manually if you need to by clicking on its thumbnail (first one on the left, top row):

Selecting the Foreground to Background gradient.

As you may have guessed, the Foreground to Background gradient gets its colors from your Foreground and Background colors. You can see your current
Foreground and Background colors in the color swatches near the bottom of the Tools panel. The swatch in the upper left shows the Foreground color,
and the one in the lower right shows the Backgroundcolor. By default, the Foreground color is set to black and the Background color is set to white:

The current Foreground (upper left) and Background (lower right) colors.

Since it's based on your current Foreground and Background colors, the Foreground to Background gradient is the easiest of all the gradients to customize
and the one that often proves most useful. Let's use it to help us learn how to actually draw a gradient, and along the way, we'll see how easy it is to change
its colors to whatever we need!
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Specifying and Adjusting Colors color model

Probably everyone who is engaged in advertising, had to hear such phrases as “light model”, “print file should be in CMYK, and for posting on the site – 
RGB”. Some may even know about the existence of such color models as GreyScale, LAB, HSB and HLS. But what exactly are these “Color models”? 
How is CMYK color model different from RGB or LAB?
We live in this white light. And this light can be divided into many different hues. As far as we know, the first who came up with this idea was Isaac 
Newton. He divided the light through the prism to seven primary colors: red, orange, yellow, green, blue, indigo and violet. We’ll talk about this 
phenomenon afterward. But now we divide the light into three basic hue (color), because it is convenient.

RGB color model

Each color TV or monitor of your computer is based on the principle of the division of the light. If say roughly, the monitor on which you now see is a
huge number of points (their number determines the horizontal and vertical resolution of the monitor), and each point of light has three “bulbs”: red, green
and blue. Each “bulb” can shine with different brightness and cannot shine at all. If only shines blue “bulb” – we see the blue dot. If only the red – we can
see the red dot. Similarly, with green. If all the lights are shining with full brightness at one point, then this point turns white, as all gradations of white
come together again. If no light shines, the point seems to us black. Since black – the absence of light. Combining the colors of these “bulbs”, glowing
with different brightness, we can obtain different colors and hues.

Brightness of each bulb is determined by the intensity (division) from 0 (“bulb”is off) to 255 (“bulb”, that luminous with full power). This division is
called – RGB color model, from the first letters of the words “RED”, “GREEN” and “BLUE”.

Thus, white color of our dot in RGB color model can be written as:

R – 255, G – 255, B – 255

“Saturated” red can be written as:

R – 255, G – 0, B – 0

Black:

R – 0, G – 0, B – 0

Yellow will be the following:

R – 255, G – 255, B – 0

You also need to know, that in order to record colors in rgb, we usually use the hexadecimal system. Intensity indicators are recorded in order of #RGB:

White – #ffffff, Red – #ff0000, Black – #00000, Yellow – #ffff00

CMYK color model

So now we know the tricky way our computer sends us the color of a particular point. Let’s now use the acquired knowledge and try to get the white color
with paints. Let’s buy three jars of paints: red, blue and green, and mix them. Did it work? I did not get. What is the problem?
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The problem is that our monitor emits light, so the color is lit. But the nature of many of the objects do not have this property. They simply reflect the
white light that falls on them. And if the subject reflects the entire spectrum of white light, we see it in white, but if some of that light is absorbed by them
– we see it is not all white.

Something like this: we shine on the red thing with white light. White light can be represented as R-255 G-255 B-255. But the thing does not want to
reflect all the light that we have sent to it, and it is brazenly stealing from us all hues of green and blue. As a result, it reflects only the R-255 G-0 B-0. That
is why it seems to us as red.

So, it is very problematic to use the RGB color model for printing on paper. For printing, as a rule, we use another color model – CMY or CMYK. CMY
color model is based on the fact that initially we have a white sheet of paper, and it reflects (virtually) the entire spectrum of RGB, and all inks applied to
it, act as filters, each of which “steals” own color (red, or green, or blue). Thus, these color inks are determined by subtracting one from the white colors
RGB. We get colors: Cyan (light blue), Magenta (or we can say pink) and Yellow.

As you remember, gradation of each color (in RGB color model) is brightness (from 0 to 255). However, in CMYK color model, the value of each color –
is “opacity” (amount of paint) and determines the percentage from 0% to 100%.

Thus, white color can be described as follows:

C (cyan) – 0%; M (magenta) – 0%; Y (yellow) – 0%.

Red: C – 0%; M – 100%; Y – 100%.

Green: C – 100%; M – 0%; Y – 100%.

Blue: C – 100%; M – 100%; Y – 0%.

Black: C – 100%; M – 100%; Y – 100%.

However, this is possible only in theory. But in practice, we can not use CMY colors. Black color turns muddy brown (printing), gray is not similar to the
gray, it is problematic to create dark hues. For the settlement of the final color, another color is used (see the last letter in the name CMYK). Transcription
of this letter may be different:

* This may be an abbreviation of blacK. And it used the last letter, so as not to confuse it with the color Blue in RGB color model

* Printers often use the word “Contour” on this color. So, it is possible that the letter K in abbreviation CMYK – an abbreviation of the German word
“Kontur”

* It could be a short for Key-color.
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However, it is difficult to name it as ‘the key’, as it is rather complementary. And this black color is not really black. If only print this paint, it is rather gray
than black. Therefore, some people think that the letter K in CMYK stands obreviature “Kobalt” (German).

As a rule, the “black” term is used to define this color Print using CMYK colors is called “full-color” or “triad.”We need to note, that during printing,
CMYK inks do not mix. They lay down on paper as “spots” (raster) next to each other and mixed already in our’s mind, because these “spots” are very
small. That is, the image is rasterized, as otherwise the paint, getting on one another, and spreads produced moire or d

 Grayscale color model

Image in grayscale color model many people mistakenly called ‘black and white’. But it is not. Black-and-white image consists only of black and white
tones. While both grayscale has 101 hue. This is gradation of Kobalt color from 0% to 100%.

Device-dependent and device-independent color model

Color model CMYK and RGB are device-dependent, ie they depend on the way they transfer a color. They point to a specific device, how to use the
corresponding colors, but do not have information about the perception of color of the final person. Depending on the settings for brightness, contrast and
sharpness of your computer monitor, ambient light and the angle at which we look at the monitor, the color with the same parameters RGB is perceived by
us in different ways. A person’s perception of color in the color model “CMYK” depends on an even greater number of conditions, such as the properties
of the printed material (for example, glossy paper absorbs less ink than the matte color on it accordingly are more vivid and rich), especially paint,
humidity in which the paper is dried up, the characteristics of the printing press and so on

To transfer more reliable information about the color to a person, we attach (so-called) color profiles to the hardware-dependent color models. Each of
such profile contains information about a particular way of human transmission of color and adjusts the final color by the addition or removal of any
constituent of the original color settings. For example, to print on glossy film uses a color profile, cleaning 10% Cyan and adding 5% Yellow to the
original color, because of the specific features of the printing press, the film itself and other conditions. However, even attached profiles do not solve all
the problems of transfer color.

Device-independent color models do not contain any information to transfer a color to a person. They mathematically describe color perceived by man
with normal color vision.

HSB and HLS color models

The basis of this color space is already familiar rainbow wheel of RGB colorspace. Color is controlled by changing parameters such as Hue, Saturation and
Brightness

Parameter hue – the color. Defined by degrees from 0 to 360 based on the colors of the rainbow wheel.

Parameter saturation – percentage of adding to this color of the white paint (has a value from 0% to 100%).

Parameter brightness – the percentage of adding black ink also varies from 0% to 100%.

The principle is similar to one of the representations of the world in terms of art. When we add white or black paint into an existing color.

This is the easiest-to-understand color model, this is thy many web-designers like it very much. However, it has several drawbacks:
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The human eye perceives colors ofthe rainbow wheel, as colors with different brightness. For example, spectral green has the greater brightness than the
spectral blue. In the HSB color model all the colors of the circle are considered to have a brightness of 100%, which, unfortunately, is not true.

Since it is based on the color model RGB, it is still a hardware-dependent.

This color model is converted to CMYK for printing and converted to RGB for display on the monitor. So, it is very problematic to guess what color you
get in the long run.

HLS color model is very similar, it has the following meaning: Hue, Lightness and Saturation

This color model is sometimes used for light and color correction in an image

LAB color models

In this color model the color consists of:

Luminance – this is set of notions lightness and chroma

A – this is color range from green to purple

B – this is color range from blue to yellow

That is, the two indicators determine the color (in the aggregate) and one indicator measures the light.

LAB is a device-independent color model, ie it does not depend on how we transfer color. It contains color as RGB and CMYK, and grayscale, which
allows it to convert with minimal loss of image quality from one color model to another.

Another advantage is that it, unlike the color model HSB, corresponding to features of perception of color by the human eye.

This model is often used to improve image quality and converting images from one color space to another.

Painting and Drawing Tools 

The main painting tools in Adobe Photoshop are the Pencil and the Brush. The Pencil draws free form lines with a hard edge, and the Brush - draws
lines  with  a  softer  edge.  It  is  possibe  to  draw distinct  or  fuzzy lines  with  the Brush,  but  they will  always  be  a  little  soft,  because  its  edges  are
indistinguishable from the background. Lines drawn with the Pencil always have a sharp edge, because there is no interaction with the background.

Both of these tools occupy one cell in the Toolbar and are always portrayed with a pictogram of the last tool used. To choose another tool, press the right
mouse button on the arrow next to the tool and choose the required tool from the menu that appears. The menu will also appear if you press and hold the
tool's button.

To draw free lines with the Pencil or Brush, follow these steps:

 Step 1. Choose a tool from the Toolbar.

 Step 2. Set the color with which colors will be drawn.

 Step 3. Choose the parameters for the chosen tool in the Options Panel.

 Step 4. Bring the cursor over the image in the photo editor.

 Step 5. Press the left mouse button and, while keeping the button pressed, move the cursor across the image.
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Most of the parameters used to define the Pencil and Brush tools in the Options panel are the same, but there are some small differences.

Brush. The Brush parameter shows the current shape and size of the brush. To change the shape and size of the brush:

o left-click on the triangle to open the drop-down palette;

o in this palette set the size and hardness of the brush or choose the shape of the brush from the list of presets.

This  menu  can  also  be  brought  up  by  right-clicking  anywhere  in  the  image  window. 
In addition the shape and size of the brushes can be changed through the Brushes palette, which can be opened by pressingor by using the
command Window - Brushes.

Mode. The Mode parameter sets the mode used by the brush. These modes affect how the colors applied by the brush interact with the colors of
the background.

Opacity. The Opacity parameter affects the level of opacity in which a line is drawn. To change this parameter, enter a value from 1 to 100 in the
parameter's field, or press the triangle button and move the slider. At lower values of Opacity, the color of the lines drawn by the tool blend more
intensely with the backgrounds' colors.

Auto Eraser. The Auto Eraser parameter is only available for the Pencil tool. When Auto Eraser is checked, the Pencil tool draws over areas of
the backgrounds' colors with the primary color and in areas occupied by the primary color in the backgrounds' colors, but if strokes begin where
the primary color is not present, then the tool will use the primary color, which is shown at the bottom of the toolbar.

Flow. The Flow parameter affects every point of color applied by the tool. Each new application of color is opaquer than the one before. This
parameter is only available for the Brush tool.

Airbrush. The Airbrush option can also only be set for the Brush tool. When the Airbrush  is pressed the Brush tool paints a line with a
border like that of a airbrush.

The Pencil and Brush tools not only can be used to draw free form lines, but also for drawing straight lines. To draw a straight line with either tool
(vertically or horizontally) press Shift and, while holding it down, start to move the cursor in either a vertical or horizontal direction.

Retouching Images 

The editing tools do not apply paint to an image, but rather affect the colors already in an image.

Adobe Photoshop editing tools are: Blur, Sharpen, Smudge, Dodge, Burn and Sponge.

To use any of these tools, follow these steps:

 Step 1. Choose a tool from the Toolbar.

 Step 2. Set the parameters for the chosen tool in the Options Panel.

 Step 3. Bring the cursor into the image window.

 Step 4. Press the left mouse button and, while keeping it pressed, move the cursor over the image.

The Blur, Sharpen and Smudge occupy one cell in the Toolbar, represented by the icon of the last tool used. To choose another instrument, press the
triangle next to the icon and choose the desired icon from the menu that appears. This menu can also be accessed from the screen, if the icon is pressed and
held for a few moments.

Blur. The Blur tool reduces the sharpness (focus) of an image. It does this by reducing the color contrast of neighboring pixels.

Sharpen.  The Sharpen tool increases the sharpness (focus) of an image,  by increasing the contrast  of neighboring pixels.  This  results in increased
clearness and contrast of borders, and heightened detail in the image.

Smudge. The Smudge tool spreads color in an image, displacing pixels of corresponding colors. It is similar to the effect created by smearing your fingers
through wet paint. Smudge works by "grasping" a color at the beginning of a stroke and then mixing it with other colors as it is dragged across the image.

The following parameters can be changed for these tools in the Options Panel: Brush, Mode, Strength, Use All Users, Finger Painting.

Brush. The Brush parameter displays the current shape and size of a brush. To change the shape and size of the brush:

left-click on the triangular button to open the drop-down palette;

change the tool's size and hardness in the Options panel or choose its shape from a selection of presets.

     The  palette  can  also  be  accessed  by  right-clicking  anywhere  in  the  image  window. 
In addition the shape and size of the brush can be set in the Brushes palette, which can by opened by pressing  or with the command Window -
Brushes.

Mode. The Mode parameter affects how a tool is applied.
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Strength. When using the Blur or Sharpen tools the Strength parameter affects the extent to which the tool changes the focus (sharpness) of an
image. When using the Smudge tool this parameter defines the distance which the tool smears color in the image.

Use All Users. If All New Users is checked when using the Blur or Sharpen tools, it is possible to increase or decrease the sharpness of colors on
all visible layers of an image.

Finger Painting. This parameter is only available for the Smudge tool. If Finger Painting is checked, it will appear as if before smearing, the
"finger" has been dipped into the main color. The result is that not only are colors smeared but an additional hue is added.

Using Toning Tool

Dodge, Burn and Sponge are tools that affect tone. They are used for lightening or darkening parts of an image.

These tools occupy one cell in the Toolbar and are represented by the icon of the last tool used. To choose another tool, right-click on the triangle next to
the tool and choose the desired tool from the menu that appears. This menu can also be accessed from the screen, if you click on the icon and hold the
button down for a few moments.

Dodge. This tool lightens a part of an image, if the cursor is dragged across it.

Burn. This tool darkens a part of an image.

Sponge. The Sponge tool affects the saturation and contrast of an image.

In the options panel, the following parameters can be adjusted for Dodge and Burn: Brush, Range, Exposure and Airbrush.

Brush. The Brush parameter affects the shape and size of the tool. To change the tools' shape and size:

o press the triangular button with the left moust button, to open the drop-down palette;

o Set the size and hardnesss of the tool in the palette or choose its shape from the selection of presets.

Range. This parameter affects the mode in which the tool is applied. In Midtones mode dark and light areas are affected equally. In Shadows
mode, pixels in darker areas (shadows) are affected more. In Highlights mode pixels in lighter areas are affected more.

Exposure. This parameter affects the degree of darkening for Burn and the degree of lightening for Dodge. A value of 100% leads to the
maximum degree of darkening or lightening.

Airbrush. When the  button is pressed the tool works in dispersion mode.

The Sponge tool can be set in the Options panel with the following parameters: Brush, Mode, Flow and Airbrush.

Brush. The Brush parameter sets the shape and size of the tool. To change the tool's shape and size:

o left-click on the triangular button to open the drop-down palette;

o set the tool's size and hardness in the palette or choose a shape for the tool from the selection of pre-sets.

Mode. This parameter switches between the modes in which the tool works. When Sponge is in Desaturation mode the saturation of the primary
color decreases, while in Saturation mode it increases.

Flow. Flow affects every point of color applied with the tool. With each application of the tool, the color applied becomes opaquer.

Airbrush. When the button  is pressed the tool begins to work in dispersion mode

Zoom tool

When the Zoom tool is active, you also have additional zoom tools on the Options bar. Selecting plus (+) or minus (–) sets the default magnification of the
Zoom tool to either enlarge or reduce the image.

When you zoom in and out, Photoshop doesn’t alter the size of the document window, so your image may become too large for its window (in which case,
scroll bars appear so you can view the rest of the image) or too small (in which case, a gray border appears around the image).

PenTool

Photoshop provides multiple Pen tools to suit your use cases and creative style:

 The Curvature Pen tool lets you intuitively draw curves and straight segments.
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 The standard Pen tool lets you draw straight segments and curves with great precision.

 The Freeform Pen tool lets you draw paths as if you were drawing with pencil on a piece of paper. 

 The Magnetic Pen options let you draw a path that snaps to the edges of the defined areas in your image. 

Use the Shift+P key combination to cycle through the tools in the Pen group.

Cycle through the Pen tools using the Shift+P key combination

You can use the pen tools in conjunction with the shape tools to create complex shapes. For more information about the modes in which you can draw with
the Pen tools.

Use the Curvature Pen tool

The Curvature Pen tool lets you draw smooth curves and straight-line segments with equal ease. Create custom shapes in your designs or define precise
paths to effortlessly fine-tune your images using this intuitive tool. While doing so, create, toggle, edit, add,  or remove smooth or corner points without
ever having to switch tools.

1. From the Pen tools group, select the Curvature Pen tool.

2. To create the first anchor point, click or tap anywhere in the document.

3. Click/tap again to define the second anchor point and complete the first segment of the path. Click once (default) if you want the next segment of
your path to be curved. Double-click if you want to draw a straight segment next.
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4.   
5.   (Curved path) Using a mouse or on a touch device, drag the pointer to draw the next segment of your path. While the mouse button is pressed

down, optimize the curve of the segment. The previous segment is automatically adjusted to keep the curve smooth.

  eep the curve smooth.

Optimize the curve of the segment while the mouse button is pressed down.

  (Curved path) Release the mouse button to drop the anchor point and complete the second segment.
  Draw additional segments and complete the path.
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  When you're done drawing, press the Esc key.

Use the standard Pen tool

Draw straight line segments

The simplest path you can draw with the standard Pen tool is a straight line, made by clicking the Pen tool to create two anchor points. By continuing to
click, you create a path made of straight line segments connected by corner points.

Clicking the Pen tool creates straight segments.

1. Select the Pen tool.
2. Position the Pen tool where you want the straight segment to begin, and click to define the first anchor point (do not drag).

1. Click again where you want the segment to end (Shift-click to constrain the angle of the segment to a multiple of 45°).

2. Continue clicking to set anchor points for additional straight segments.

The last anchor point you add always appears as a solid square, indicating that it is selected. Previously defined anchor points become hollow, and
deselected, as you add more anchor points.

3. Complete the path by doing one of the following:

 To close the path, position the Pen tool over the first (hollow) anchor point. A small circle appears next to the Pen tool pointer   when
it is positioned correctly. Click or drag to close the path.

 To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere away from all objects.

To leave the path open, you can also select a different tool.

Draw curves with the standard Pen tool

You create a curve by adding an anchor point where a curve changes direction, and dragging the direction lines that shape the curve. The length and slope
of the direction lines determine the shape of the curve.

Curves are easier to edit and your system can display and print them faster if you draw them using as few anchor points as possible. Using too many points
can also introduce unwanted bumps in a curve. Instead, draw widely spaced anchor points, and practice shaping curves by adjusting the length and angles
of the direction lines.
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1. Select the Pen tool.
2. Position the Pen tool where you want the curve to begin and hold down the mouse button.

The first anchor point appears, and the Pen tool pointer changes to an arrowhead. (In Photoshop, the pointer changes only after you’ve started dragging.)

3. Drag to set the slope of the curve segment you’re creating, and then release the mouse button.

In general, extend the direction line about one third of the distance to the next anchor point you plan to draw. (You can adjust one or both sides of the
direction line later.)

Hold down the Shift key to constrain the tool to multiples of 45°.

Drawing the first point in a curve

A. Positioning Pen tool B. Starting to drag (mouse button pressed) C. Dragging to extend direction lines 

4. Position the Pen tool where you want the curve segment to end, and do one of the followings:

 To create a C-shaped curve, drag in a direction opposite to the previous direction line. Then release the mouse button.

Drawing the second point in a curve

 To create an S-shaped curve, drag in the same direction as the previous direction line. Then release the mouse button.

Drawing an S curve

Finish drawing a path

1. Complete a path in one of the following ways:

 To close a path, position the Pen tool over the first (hollow) anchor point. A small circle appears next to the Pen tool pointer   when it
is positioned correctly. Click or drag to close the path.

 To leave a path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere away from all objects.

Settings in the Options bar

When you use the standard Pen tool, the following options are available in the options bar:
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 Auto Add/Delete, which lets you add an anchor point when you click a line segment or delete an anchor point when you click it.

 Rubber Band, which lets you preview path segments as you move the pointer between clicks. To access this option, click the pop-up menu to the
right of the Custom Shape icon.

Use the Freeform Pen tool

The Freeform Pen tool lets you draw as if you were drawing with a pencil on paper. Anchor points are added automatically as you draw. You do not
determine where the points are positioned, but you can adjust them once the path is complete. To draw with greater precision, use the Pen tool.

1. Select the Freeform Pen tool .

2. To control how sensitive the final path is to the movement of your mouse or stylus, click the inverted arrow next to the shape buttons in the
options bar, and enter a value between 0.5 and 10.0 pixels for Curve Fit. A higher value creates a simpler path with fewer anchor points.

3. Drag the pointer in the image. As you drag, a path trails behind the pointer. When you release the mouse, a work path is created.

4. To continue the existing freehand path, position the pen pointer on an end point of the path, and drag.

5. To complete the path, release the mouse. To create a closed path, drag the line to the initial point of the path (a circle appears next to the pointer
when it is aligned).

Using channels

Channels are grayscale images that store different types of information:

 Color information channels are created automatically when you open a new image. The image’s color mode determines the number of color
channels created. For example, an RGB image has a channel for each color (red, green, and blue) plus a composite channel used for editing the image.

 Alpha channels store selections as grayscale images. You can add alpha channels to create and store masks, which let you manipulate or protect
parts of an image. 

 Spot color channels specify additional plates for printing with spot color inks. An image can have up to 56 channels. All new channels have the
same dimensions and number of pixels as the original image.

The file size required for a channel depends on the pixel information in the channel. Certain file formats, including TIFF and Photoshop formats, compress
channel information and can save space. The size of an uncompressed file, including alpha channels and layers, appears as the right-most value in the
status bar at the bottom of the window when you choose Document Sizes from the pop-up menu.

Channels panel overview

The Channels panel lists all channels in the image—composite channel first (for RGB, CMYK, and Lab images). A thumbnail of the channel’s contents
appears to the left of the channel name; the thumbnail is automatically updated as you edit the channel.

Channel types
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A. Color channels B. Spot channels C. Alpha channels 

Display the Channels panel

1. Choose Windows > Channels.

Resize or hide channel thumbnails

1. Choose Panel Options from the Channels panel menu. Click a thumbnail size or click None to turn off the display of thumbnails.

Viewing thumbnails is a convenient way of tracking channel contents; however, turning off the display of thumbnails can improve performance.

Show or hide a channel

You can use the Channels panel to view any combination of channels in the document window. For example, you can view an alpha channel and the
composite channel together to see how changes made in the alpha channel relate to the entire image.

1. Click in the eye column next to the channel to show or hide that channel. (Click the composite channel to view all default color channels. The
composite channel is displayed whenever all the color channels are visible.)

Show color channels in color

Individual channels are displayed in grayscale. In RGB, CMYK, or Lab images, you can view the individual channels in color. (In Lab images, only
the a and b channels appear in color.) If more than one channel is active, the channels always appear in color.

You can change the default to show the individual color channels in color. When a channel is visible in the image, an eye icon   appears to its left in the
panel.

1. Do one of the followings:

 In Windows, choose Edit > Preferences > Interface.

 In Mac OS, choose Photoshop > Preferences > Interface.

2 Select Show Channels inColor and click OK.

Select and edit channels

You can select one or more channels in the Channels panel. The names of all selected, or active, channels are highlighted.

Selecting multiple channels

A. Not visible or editable B. Visible but not selected for editing C. Selected for viewing and editing D. Selected for editing but not viewing 

 To select a channel, click the channel name. Shift-click to select (or deselect) multiple channels.
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 To edit a channel, select it and then use a painting or editing tool to paint in the image. You can paint on only one channel at a time. Paint with
white to add the selected channel’s color at 100% intensity. Paint with a value of gray to add the channel’s color at a lower intensity. Paint with black to
fully remove the channel’s color.

Rearrange and rename alpha and spot channels

You can move alpha or spot channels above the default color channels only if the image is in Multichannel mode (Image > Mode > Multichannel). For
information about that mode’s limitations, 

To change the order of alpha or spot channels, drag the channel up or down in the Channels panel. When a line appears in the position you want, release
the mouse button.

 To rename an alpha or spot channel, double-click the channel’s name in the Channels panel, and enter a new name.

Delete a channel

You may want to delete spot or alpha channels you no longer need before saving an image. Complex alpha channels can substantially increase the disk
space required for an image.

1. In Photoshop, select the channel in the Channels panel and do one of the followings:

 Alt-click (Windows) or Option-click (Mac OS) the Delete icon .

 Drag the channel name in the panel to the Delete icon.

 Choose Delete Channel from the Channels panel menu.

 Click the Delete icon at the bottom of the panel, and then click Yes.

LAYER
A layer is simply one image stacked on top of another. Imagine I have a piece of paper and I paint it red. Then I take a piece of clear cellophane
and paint a yellow circle and lay it over the paper. Now I take another piece of cellophane and paint some blue type and laythat on top of the
yellow circle. I now have a background (red) and 2 layers (yellow and blue.) Just like in the picture below.
A background with 2 layers.

This is how your image with would look on the screen or when printed.

Broken apart so you can see how the layers work
Each layer stacks on top of the previous one.

That is, it! The concept of layers is that simple. Photoshop uses the Layers Pallete to allow you to do this with your images. More than one layer
is called a composition.

LAYERS PANEL

Photoshop’s layers  Panel  is  a  powerful  tool  that  allows  you  do many special  things  to  your  layed  compositions.  Next,  we  will  look at  the
Photoshop layers pallete.
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Have you ever wondered what all the parts of a layer’s panel do? Here is a screen grab of the layers Panel. I’ll explain what all the parts are here.

Layer Filter: This enables you to hide layers based on different things. Makes it easier to find the layers that you want to work with.

Opacity: 0= transparent 100 = fully opaque. press number keys on keyboard to instantly set to multiples of 10 or adjust the slider for an exact
amount of transparency on each layer.

Blend Modes: Change these to change the way that the selected layer blends with the layers underneath it. Great for compositing and special
effects. (With the move tool selected, press Shift+ or Shift- to cycle through blending modes.

Fill opacity: Adjusts the amount of opacity of the pixels only, but any layer styles are unaffected and remain 100% opaque.

visibility: If the eye is showing that layer is visible. Click on the eye and the layer will still be there but invisible until you click on the eye
again.

Locked: The padlock means that something is locked in the layer. (Also click in the 4 icons in the “lock” next to fill opacity to make certain
things editable of locked). Here are the different things that can be locked/unlocked.

Lock  all: If  the  box  is  checked  the  layer  is  totally  protected  from  any  editing.
Lock  Position: You  can  make  any  changes  except  for  moving  the  image.
Lock  Image  pixels: You  cannot  draw  on  this  layer  if  checked.
Lock  transparent: You  can  paint  on  this  layer  but  not  where  it  is  transparent.
Useful tools at the bottom of the panel

Link: Enabled you to link layers. These will all move together unless unlinked.

Layer Effects (Styles): Special effects applied to your image layer. Noted by the little f. Each effect will be listed. multiple effects may be used
at once.

Add Layer Mask: This is the button to press to add a layer mask to the currently selected layer. Allows you to paint away parts of your layer
without damaging your original image.

Add Adjustment Layer: The best way to apply image adjustments.  There can change the color or tone of an image.  All  layers  are affected
underneath  an  adjustment  layer  (Unless  clipped).  This  is  a  good  option  to  using  Image>Adjustments  because  adjustment  layers  are  non-
destructive and re editable.

Layer Groups: A good organizational tool. This puts layers into a folder. You can choose multiple layers and press Cmd/Ctrl+G to put them in a
group or create a group by clicking this icon. Layers can be dragged in or out of groups in the Layers panel.

Create New Layer: Press this icon to create a new layer. Drag an existing layer into this icon to create a duplicate of that layer,

Delete Layer: Drag a layer into this icon to remove it. Or select the layer and then press this icon to get the same result.

Panel Options: This will open a drop-down menu that provides a number of options, many that aren’t listed anywhere else.
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Photoshop actions enable you to record a repetitive process and save that information as an action which you can then use for other tasks down the road.
Not only that, you can edit actions after the fact and customize them to suit your needs.

An action is a series of tasks that you play back on a single file or a batch of files—menu commands, panel options, tool actions, and so on. For example,
you can create an action that changes the size of an image, applies an effect to the image, and then saves the file in the desired format.

Actions can include steps that let you perform tasks that cannot be recorded (for example, using a painting tool). Actions can also include modal controls
that let you enter values in a dialog box while playing an action.

In Photoshop, actions are the basis for droplets, which are small applications that automatically process all files that are dragged onto their icon.

Photoshop and Illustrator come with predefined actions installed that help you perform common tasks. You can use these actions as is, customize them to
meet your needs, or create new actions. Actions are stored in sets to help you organize them.

You can record, edit, customize, and batch-process actions, and you can manage groups of actions by working with action sets.

01. Open the Actions panel

When you open the Actions panel in Photoshop CC this is what you see. Note all the actions which are included, which you can use immediately.

Before beginning to record actions, it is a good idea to close the Default Actions and create a New Set with your name.

Click on the icon at the top right of the Actions panel. When the pop-up appears, choose New Set and in the dialog box that appears immediately after that,
type in your name and click on OK.

A new set appears with your name.

02. Record your action

Recording an action is easy. Simply click on the icon at the top right of the Actions panel and in the popup, menu click on New Action.

In the New Action dialog box, type in the name of your action and click on Record.

All the steps you take will be recorded in the Actions panel.

What you will find is that creating an action is often a process of experimentation to get the affects you desire. To end the recording, press the stop button.

03. Play the action

When playing actions, you have a few options. To access those, click on the icon at the top-right of the Actions panel and in the pop-up menu, click on

Playback Options.

This brings up the Playback Options dialog box. You have three choices: Accelerated, Step by Step and Pause For.

Accelerate will play the action at normal speed. Be aware that when you do so, you might not be able to see what the action is doing to your file. If you
want to see how the Action performs, choose the Step by Step option instead.
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The third option, pause for ___ Seconds allows you to set a pause between each step of the action. This could be useful for debugging if you are having
trouble with the execution of the action.

04. Managing and editing actions

You can apply an action to other images after it has been recorded. Another way to apply actions is to go to File>Automate>Batch.

Note that at the top of the dialog box are three important drop downs. The Set heading refers to Action Sets that have been recorded. In this case, the
default action set is available.

Immediately under that is the action heading. Here, you can choose which action you want to use. The third drop down is for the source of images, which
could be a folder, import, opened files, or Bridge.

05. For best results

Take some time to plan the steps of the actions before recording them and if necessary, write down all the steps on a piece of paper before you begin.
While you can edit actions after the fact, it is a better use of your time to work out any potential problems before you begin recording.

It is also a good idea to keep a log of the actions you record with all the steps in case you need to make changes later.

Path segments, components, and points

A path consists of one or more straight or curved segments. Anchor points mark the end points of the path segments. On curved segments, each selected
anchor point displays one or two direction lines, ending in direction points. The positions of direction lines and points determine the size and shape of a
curved segment. Moving these elements reshapes the curves in a path.

A path

A. Curved line segment B. Direction point C. Direction line D. Selected anchor point E. Unselected anchor point 

A path can be closed, with no beginning or end (for example, a circle), or open, with distinct end points (for example, a wavy line).

Smooth curves are connected by anchor points called smooth points. Sharply curved paths are connected by corner points.

Smooth point and corner point

When you move a direction line on a smooth point, the curved segments on both sides of the point are adjusted simultaneously. By comparison, when you
move a direction line on a corner point, only the curve on the same side of the point as the direction line is adjusted.

Adjusting a smooth point and a corner point

A path does not have to be one connected series of segments. It can contain more than one distinct and separate  path component. Each shape in a shape
layer is a path component, as described by the layer’s clipping path.
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Separate path components selected

Select a path
Selecting a path component or path segment displays all of the anchor points on the selected portion, including any direction lines and direction points if
the selected segment is curved. Direction handles appear as filled circles, selected anchor points as filled squares, and unselected anchor points as hollow
squares.

1. Do one of the following:

 To select a path component (including a shape in a shape layer), select the Path Selection tool  , and click anywhere inside the path
component. If a path consists of several path components, only the path component under the pointer is selected.

 To select a path segment, select the Direct Selection tool , and click one of the segment’s anchor points, or drag a marquee over part
of the segment.

Drag a marquee to select segments.

2 To select additional path components or segments, select the Path Selection tool or the Direct Selection tool, and then hold down Shift while selecting
additional paths or segments.

Note:

When the Direct Selection tool is selected, you can select the entire path or path component by Alt-clicking (Windows) or Option-clicking (Mac  OS)
inside the path.  To activate  the Direct Selection tool when most  other  tools are selected,  position the pointer over  an anchor  point,  and press Ctrl
(Windows) or Command (Mac OS).

Select multiple paths | Photoshop CC
You can select multiple paths on the same layer or across different layers.

1. In the Paths panel, do any of the following to make the paths visible:
 Shift-click to select contiguous paths.

 Ctrl-click (Windows) or Command-click (Mac OS) to select non-contiguous paths.
2 Select the Path Selection tool or the Direct Selection tool and do any of the following:
 Drag over the segments.

 Shift-click the paths.
3 To select additional path components or segments, select the Path Selection tool or the Direct Selection tool, and then hold down the Shift key while

selecting additional paths or segments.
Note:
You can choose to work with paths in the isolation mode. To isolate only the layer containing a path, with the path active, double-click using a selection
tool. You can also isolate single or multiple layers by using the Select/Isolate Layers menu item or by setting Layer Filtering to Selected.

You can exit the isolation mode in several ways, such as:

 Turning off Layer Filtering
 Switching Layer Filtering to something other than Selected
 Double-clicking away from a path using the path selection tools 

Reorder paths
You can reorder saved paths that are not Shape, Type, or Vector Mask paths in the Paths panel.

1. In the Paths panel, drag the path to the position you want. In Photoshop CC, you can select and drag more than one path simultaneously.
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Duplicate paths
1. In the Paths panel, select the path you want to duplicate. In Photoshop CC, you can select more than one path.
2. Do any of the following:
 Alt-drag (Windows) or Option-drag the paths.

 Choose Duplicate Path from the panel menu.

Specify path options
You can define the color and thickness of path lines to suit your taste and for easier visibility.While creating a path—using the Pen tool, for example—

click the gear icon ( ) in the Options bar. Now specify the color and thickness of path lines. Also, specify whether you want to preview path segments as
you move the pointer between clicks (Rubber Band effect).

Path options: Thickness and Color

Adjust path segments
You can edit a path segment at any time, but editing existing segments is slightly different from drawing them. Keep the following tips in mind when
editing segments:

 If an anchor point connects two segments, moving that anchor point always changes both segments.

 When drawing with the Pen tool, you can temporarily activate the Direct Selection tool so that you can adjust segments you’ve already drawn;
press Ctrl (Windows) or Command (Mac OS) while drawing.

 When you initially draw a smooth point with the Pen tool, dragging the direction point changes the length of the direction line on both sides of
the point. However, when you edit an existing smooth point with the Direct Selection tool, you  change the length of the direction line only on the side
you’re dragging.

Move straight segments

1. With the Direct Selection tool , select the segment you want to adjust.
2. Drag the segment to its new position.
Adjust the length or angle of straight segments

1. With the Direct Selection tool select an anchor point on the segment you want to adjust.

2. Drag the anchor point to the desired position. Shift-drag to constrain the adjustment to multiples of 45°.
Adjust the position or shape of curved segments

1. With the Direct Selection tool ,, select a curved segment, or an anchor point on either end of the curved segment. Direction lines appear, if any
are present. (Some curved segments use just one direction line.)

2. Do any of the following:

 To adjust the position of the segment, drag the segment. Shift-drag to constrain the adjustment to multiples of 45°.

Click to select the curve segment. Then drag to adjust.

 To adjust the shape of the segment on either side of a selected anchor point, drag the anchor point or the direction point. Shift-drag to
constrain movement to multiples of 45°.
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Drag the anchor point or drag the direction point.

Note:

Adjusting a path segment also adjusts the related segments, letting you intuitively transform path shapes. To only edit segments between the selected
anchor points, similar to earlier Photoshop versions, select Constrain Path Dragging in the options bar.

Note:

You can also apply a transformation, such as scaling or rotating, to a segment or anchor point.

Delete a segment

1. (Optional) If you’re creating an opening in a closed path, select the Add Anchor Point tool  , and add two points where you want the cut to
occur.

2. Select the Direct Selection tool , and select the segment you want to delete.
3. Press Backspace (Windows) or Delete (Mac OS) to delete the selected segment. Pressing Backspace or Delete again erases the rest of the path.
Delete the direction line of an anchor point

 Using the Convert Anchor Point tool, click the anchor point of the direction line.
The smooth point becomes a corner point.
Extend an open path

1. Using the Pen tool,  position the pointer over the endpoint of the open path you want to extend.  The pointer changes when it’s precisely
positioned over the endpoint.

2. Click the endpoint.
3. Do one of the followings:

 To create a corner point, position the Pen tool where you want to end the new segment, and click. If you are extending a path that ends
at a smooth point, the new segment will be curved by the existing direction line.

 To create a smooth point, position the Pen tool where you want to end the new curved segment, and drag.

Connect two open paths
1. Using the Pen tool, position the pointer over the endpoint of the open path that you want to connect to another path. The pointer changes when

it’s precisely positioned over the endpoint.
2. Click the endpoint.
3. Do one of the following:

 To connect the path to another open path, click an endpoint on the other path. When you precisely position the Pen tool over the other

path’s endpoint, a small merge symbol  appears next to the pointer.

 To connect a new path to an existing path, draw the new path near the existing path, and then move the Pen tool to the existing path’s
(unselected) endpoint. Click that endpoint when you see the small merge symbol that appears next to the pointer.

Move or nudge anchor points or segments using the keyboard
1. Select the anchor point or path segment.
2. Click or hold down any of the arrow keys on the keyboard to move 1 pixel at a time in the direction of the arrow.

Hold down the Shift key in addition to the arrow key to move 10 pixels at a time.

Add or delete anchor points
Adding anchor points can give you more control over a path or it can extend an open path. However, try not to add more points than necessary. A path with
fewer points is easier to edit, display, and print. You can reduce the complexity of a path by deleting unnecessary points.

The toolbox contains three tools for adding or deleting points: The Pen tool , the Add Anchor Point tool , and the Delete Anchor Point tool .

By default, the Pen tool changes to the Add Anchor Point tool as you position it over a selected path, or to the Delete Anchor Point tool as you position it
over an anchor point. You must select Auto Add/Delete in the options bar to enable the Pen tool to automatically change to the Add Anchor Point or Delete
Anchor Point tool.

You can select and edit multiple paths simultaneously. You can also reshape a path while adding anchor points by clicking and dragging as you add.

Note:

Don’t use the Delete or Backspace keys or the Edit > Cut or Edit > Clear commands to delete anchor points. These keys and commands delete the point
and line segments that connect to that point.

Add or delete anchor points
1. Select the path you want to modify.
2. Select the Pen tool, the Add Anchor Point tool, or the Delete Anchor Point tool.

26



Multimedia Application

3. To add an anchor point, position the pointer over a path segment and click. To delete an anchor point, position the pointer over an anchor point
and click.

Disable or temporarily override automatic Pen tool switching
You can override automatic switching of the Pen tool to the Add Anchor Point tool or the Delete Anchor Point tool. This is useful when you want to start a
new path on top of an existing path.

 In Photoshop, deselect Auto Add/Delete in the options bar.

Convert between smooth points and corner points
1. Select the path you want to modify.
2. Select the Convert Point tool or use the Pen tool and hold down Alt (Windows) or Option (Mac OS).
Note:

To activate the Convert Point tool while the Direct Selection tool is selected, position the pointer over an anchor point, and press Ctrl+Alt (Windows) or
Command+Option (Mac OS).

3. Position the Convert Point tool over the anchor point you want to convert, and do one of the followings:

 To convert a corner point to a smooth point, drag away from the corner point to make direction lines appear.

Dragging a direction point out of a corner point to create a smooth point

 To convert a smooth point to a corner point without direction lines, click the smooth point.

Clicking a smooth point to create a corner point

 To convert a corner point without direction lines to a corner point with independent direction lines, first drag a direction point out of a
corner point (making it a smooth point with direction lines). Release the mouse button only (don’t release any keys you may have pressed to activate
the Convert Anchor Point tool), and then drag either direction point.

 To convert a smooth point to a corner point with independent direction lines, drag either direction point.

Converting a smooth point to a corner point

Adjust path components
You can reposition a path component (including a shape in a shape layer) anywhere within an image. You can copy components within an image or
between two Photoshop images. Using the Path Selection tool, you can merge overlapping components into a single component. All  vector objects,
whether they are described by a saved path, work path, or vector mask, can be moved, reshaped, copied, or deleted.

You can also use the Copy and Paste commands to duplicate vector objects between a Photoshop image and an image in another application, such as
Adobe Illustrator.

Change the overlap mode for the selected path component

1. Using the Path Selection tool , drag a marquee to select existing path areas.
2. Choose a shape area option from the Path Operations drop-down menu in the options bar:
Combine Shapes 
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Adds the path area to overlapping path areas.

Subtract From Shape Area 
Removes the path area from overlapping path areas.

Intersect Shape Areas 
Restricts the area to the intersection of the selected path area and overlapping path areas.

Exclude Overlapping Shape Areas 
Excludes the overlap area.

Show or hide the selected path component
Do one of the following:

 Choose View > Show > Target Path.
 Choose View > Extras. This command also shows or hides a grid, guides, selection edges, annotations, and slices.

Move a path or path component

1. Select the path name in the Paths panel, and use the Path Selection tool   to select the path in the image. To select multiple path components,
Shift-click each additional path component to add it to the selection.

2. Drag the path to its new location. If you move any part of a path beyond the canvas boundaries, the hidden part of the path is still available.

Dragging a path to a new location

Note:

If you drag a path so that the move pointer is over another open image, the path is copied to that image.

Reshape a path component

1. Select the path name in the Paths panel, and use the Direct Selection tool  to select an anchor point in the path.
2. Drag the point or its handles to a new location.
Merge overlapping path components

1. Select the path name in the Paths panel, and select the Path Selection tool .
2. To create a single component from all overlapping components, choose Merge Shape Components from the Path Operations drop-down menu in

the options bar.
Copy a path component or path
Do any of the following:

 To copy a path component as you move it, select the path name in the Paths panel, and click a path component with the Path Selection tool  .
Then Alt-drag (Windows) or Option-drag (Mac OS) the selected path.

 To copy a path without renaming it, drag the path name in the Paths panel to the New Path button  at the bottom of the panel.

 To copy and rename a path, Alt-drag (Windows) or Option-drag (Mac OS) the path in the Paths panel to the New Path button at the bottom of the
panel. Or select the path to copy, and choose Duplicate Path from the Paths panel menu. Enter a new name for the path in the Duplicate Path dialog box,
and click OK.

 To copy a path or path component into another path, select the path or path component you want to copy, and choose Edit  > Copy. Then select
the destination path, and choose Edit > Paste.

Copy path components between two Photoshop files
1. Open both images.

2. In the source image, use the Path Selection tool  to select the entire path or the path components that you want to copy.
3. To copy the path component, do any of the following:

 Drag the path component from the source image to the destination image. The path component is copied to the active path in the Paths
panel.

 In the source image, select the path name in the Paths panel and choose Edit  > Copy to copy the path. In the destination image, choose
Edit > Paste. You can also use this method to combine paths in the same image.

 To paste the path component into the destination image, select the path component in the source image, and choose Edit  > Copy. In the
destination image, choose Edit > Paste.

Delete a path component
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1. Select the path name in the Paths panel, and click a path component with the Path Selection tool .
2. Press Backspace (Windows) or Delete (Mac OS) to delete the selected path component.
Align and distribute path components
You can align and distribute path components that are described in a single path. For example, you can align the left edges of several shapes contained in a
single layer or distribute several components in a work path along their horizontal centers.
Note:

To align shapes that are on separate layers, use the Move tool.

 To align components, use the Path Selection tool  to select the components you want to align. Then choose an option from the Path Alignment
drop-down menu in the options bar.

Alignment options

 To distribute components, select at least three components you want to distribute. Then choose an option from the Path Arrangement drop-down
menu in the options bar.

Distribute options

Channels are grayscale images that store different types of information:

 Color information channels are created automatically when you open a new image. The image’s color mode determines the number of color
channels created. For example, an RGB image has a channel for each color (red, green, and blue) plus a composite channel used for editing the image.

 Alpha channels store selections as grayscale images. You can add alpha channels to create and store masks, which let you manipulate or protect
parts of an image.

 Spot color channels specify additional plates for printing with spot color inks.

 An image can have up to 56 channels. All new channels have the same dimensions and number of pixels as the original image.

The file size required for a channel depends on the pixel information in the channel. Certain file formats, including TIFF and Photoshop formats, compress
channel information and can save space. The size of an uncompressed file, including alpha channels and layers, appears as the right-most value in the
status bar at the bottom of the window when you choose Document Sizes from the pop-up menu.

 Note:

As long as you save a file in a format supporting the image’s color mode, the color channels are preserved. Alpha channels are preserved only when you
save a file in Photoshop, PDF, TIFF, PSB, or raw formats. DCS 2.0 format preserves only spot channels. Saving in other formats may cause channel
information to be discarded.

Channels panel overview
The Channels panel lists all channels in the image—composite channel first (for RGB, CMYK, and Lab images). A thumbnail of the channel’s contents
appears to the left of the channel name; the thumbnail is automatically updated as you edit the channel.

Channel types
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A. Color channels B. Spot channels C. Alpha channels 

Display the Channels panel

1. Choose Windows > Channels.
Resize or hide channel thumbnails

1. Choose Panel Options from the Channels panel menu. Click a thumbnail size or click None to turn off the display of thumbnails.
Viewing thumbnails is a convenient way of tracking channel contents; however, turning off the display of thumbnails can improve performance.

Show or hide a channel
You can use the Channels panel to view any combination of channels in the document window. For example, you can view an alpha channel and the
composite channel together to see how changes made in the alpha channel relate to the entire image.

1. Click in the eye column next to the channel to show or hide that channel. (Click the composite channel to view all default color channels. The
composite channel is displayed whenever all the color channels are visible.)

Note:

To show or hide multiple channels, drag through the eye column in the Channels panel.

Show color channels in color
Individual channels are displayed in grayscale. In RGB, CMYK, or Lab images, you can view the individual channels in color. (In Lab images, only
the a and b channels appear in color.) If more than one channel is active, the channels always appear in color.

You can change the default to show the individual color channels in color. When a channel is visible in the image, an eye icon   appears to its left in the
panel.

1. Do one of the followings:

 In Windows, choose Edit > Preferences > Interface.

 In Mac OS, choose Photoshop > Preferences > Interface.

2 Select Show Channels in Color and click OK.

Select and edit channels
You can select one or more channels in the Channels panel. The names of all selected, or active, channels are highlighted.

Selecting multiple channels

A. Not visible or editable B. Visible but not selected for editing C. Selected for viewing and editing D. Selected for editing but not viewing 

 To select a channel, click the channel name. Shift-click to select (or deselect) multiple channels.

 To edit a channel, select it and then use a painting or editing tool to paint in the image. You can paint on only one channel at a time. Paint with
white to add the selected channel’s color at 100% intensity. Paint with a value of gray to add the channel’s color at a lower intensity. Paint with black to
fully remove the channel’s color.

Rearrange and rename alpha and spot channels

You can move alpha or spot channels above the default color channels only if the image is in Multichannel mode (Image > Mode > Multichannel). For
information about that mode’s limitations.
To change the order of alpha or spot channels, drag the channel up or down in the Channels panel. When a line appears in the position you want, release
the mouse button.
Note:
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Spot colors are overprinted in the order of their appearance from top to bottom in the Channels panel.

 To rename an alpha or spot channel, double-click the channel’s name in the Channels panel, and enter a new name.

Delete a channel
You may want to delete spot or alpha channels you no longer need before saving an image. Complex alpha channels can substantially increase the disk
space required for an image.

1. In Photoshop, select the channel in the Channels panel and do one of the followings:

 Alt-click (Windows) or Option-click (Mac OS) the Delete icon .

 Drag the channel name in the panel to the Delete icon.

 Choose Delete Channel from the Channels panel menu.

 Click the Delete icon at the bottom of the panel, and then click Yes.

About Photoshop layers

Photoshop layers are like sheets of stacked acetate. You can see through transparent areas of a layer to the layers below. You move a layer to position the
content on the layer, like sliding a sheet of acetate in a stack. You can also change the opacity of a layer to make content partially transparent.

Transparent areas on a layer let you see layers below.

You use layers to perform tasks such as compositing multiple images, adding text to an image, or adding vector graphic shapes. You can apply a layer style
to add a special effect such as a drop shadow or a glow.

Introduction to layers
Organizing Photoshop layers
A new image has a single layer. The number of additional layers, layer effects, and layer sets you can add to an image is limited only by your computer’s
memory.

You work with layers in the Layers panel. Layer groups help you organize and manage layers. You can use groups to arrange your layers in a logical order
and to reduce clutter in the Layers panel. You can nest groups within other groups. You can also use groups to apply attributes and masks to multiple layers
simultaneously.

Photoshop layers for non-destructive editing
Sometimes layers don’t contain any apparent content. For example, an adjustment layer holds color or tonal adjustments that affect the layers below it.
Rather than edit image pixels directly, you can edit an adjustment layer and leave the underlying pixels unchanged.
A special type of layer, called a Smart Object, contains one or more layers of content. You can transform (scale, skew, or reshape) a Smart Object without
directly editing image pixels. Or, you can edit the Smart Object as a separate image even after placing it in a Photoshop image. Smart Objects can also
contain smart filter effects, which allow you to apply filters non-destructively to images so that you can later tweak or remove the filter effect. 
Video layers
You can use video layers to add video to an image. After importing a video clip into an image as a video layer, you can mask the layer, transform it, apply
layer effects, paint on individual frames, or rasterize an individual frame and convert it to a standard layer. Use the Timeline panel to play the video within
the image or to access individual frames.

Photoshop Layers panel overview
The Layers panel in Photoshop lists all layers, layer groups, and layer effects in an image. You can use the Layers panel to show and hide layers, create
new layers, and work with groups of layers. You can access additional commands and options in the Layers panel menu.

Photoshop Layers panel
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A. Layers panel menu B. Filter C. Layer Group D. Layer E. Expand/Collapse Layer effects F. Layer effect G. Layer thumbnail 

Display the Photoshop Layers panel
1. Choose Window > Layers.

Choose a command from the Photoshop Layers panel menu
1. Click the triangle in the upper-right corner of the panel.

Change the size of Photoshop layer thumbnails
1. Choose Panel Options from the Layers panel menu and select a thumbnail size.

Change thumbnail contents

1. Choose Panel Options from the Layers panel menu and select Entire Document to display the contents of the entire document. Select Layer
Bounds to restrict the thumbnail to the object’s pixels on the layer.

Note:

Turn off thumbnails to improve performance and save monitor space.

Expand and collapse groups

1. Click the triangle to the left of a group folder.
Filter Photoshop layers

At the top of the Layers panel, the filtering options help you find key layers in complex documents quickly. You can display a subset of layers based on
name, kind, effect, mode, attribute, or color label.

Filter layers options in the Layers panel

1. Choose a filter type from the pop-up menu.
2. Select or enter the filter criteria.
3. Click the toggle switch to switch layer filtering on or off.

Convert background and Photoshop layers
When you create a new image with a white background or a colored background, the bottommost image in the Layers panel is called  Background. An
image can have only one background layer. You cannot change the stacking order  of a background layer, its blending mode, or its opacity. However, you
can convert a background into a regular layer, and then change any of these attributes.

When you create a new image with transparent content, the image does not have a background layer. The bottommost layer is not constrained like the
background layer; you can move it anywhere in the Layers panel and change its opacity and blending mode.

Convert a background into a Photoshop layer
1. Double-click Background in the Layers panel or choose Layer > New > Layer from Background.
2. Set layer options.
3. Click OK.
Convert a Photoshop layer into a background

1. Select a Photoshop layer in the Layers panel.
2. Choose Layer > New > Background from Layer.
Any transparent pixels in the layer are converted to the background color, and the layer drops to the bottom of the layer stack.

Note:

You cannot create a background by giving a regular layer the name, Background—you must use the Background from Layer command.

Turn the background layer into a regular layer
Duplicate Photoshop layers
You can duplicate layers within an image or into another or a new image.
Duplicate a Photoshop layer or group within an image

1. Select a layer or group in the Layers panel.
2. Do one of the followings:
 Drag the layer or group to the Create a New Layer button .
 Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers panel menu. Enter a name for the layer or group and

click OK.
Duplicate a Photoshop layer or group in another image

1. Open the source and destination images.
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2. From the Layers panel of the source image, select one or more layers or a layer group.
3. Do one of the following:

 Drag the layer or group from the Layers panel to the destination image.

 Select the Move tool , and drag from the source image to the destination image. The duplicate layer or group appears above the
active layer in the Layers panel of the destination image. Shift-drag to move the image content to the same location it occupied in the source image (if
the source and destination images have the same pixel dimensions) or to the center of the document window (if the source and destination images have
different pixel dimensions).

 Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers panel menu. Choose the destination document from
the Document pop-up menu and click OK.

 Choose Select > All to select all the pixels on the layer and choose Edit > Copy. Then choose Edit > Paste in the destination image.
(This method copies only pixels, excluding layer properties such as blending mode.)

Create a new document from a Photoshop layer or group
1. Select a layer or group from the Layers panel.
2. Choose Duplicate Layer or Duplicate Group from the Layers menu or the Layers panel menu.
3. Choose New from the Document pop-up menu and click OK.

Sample from all visible Photoshop layers

The default behavior of the Mixer Brush, Magic Wand, Smudge, Blur, Sharpen, Paint Bucket, Clone Stamp, and Healing Brush tools is to sample color
only from pixels on the active layer. This means you can smudge or sample in a single layer.

1. To smudge or sample pixels from all visible layers with these tools, select Sample All Layers from the options bar.

Change transparency preferences
1. In Windows, choose Edit > Preferences > Transparency & Gamut; in Mac OS, choose Photoshop > Preferences > Transparency & Gamut.
2. Choose a size and color for the transparency checkerboard or choose None for Grid Size to hide the transparency checkerboard.
3. Click OK.
Photoshop actions:

The first thing you need to do is to drag-and-drop a Lens Distortions filter into your photo project… Once you’ve done that, simply apply the Control
action to the filter, and you’re all set.
There are 5 different controls in each of our Photoshop actions:

 Controls (i.e. “Light Hit Controls”)
 Toolkit – Softness +
 Toolkit – Sharpen +
 Toolkit – Fix Banding
 Reset Group

Controls
This is the primary action you’ll use and applies all the default Lens Distortion settings to your filter. To use it, select the Lens Distortions filter you want
to apply it to, then click the little “play” button in the actions panel.
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Toolkit – Softness +
Once you’ve applied the Controls action above, you can use this action to add some Softness to the filter. Open the main filter folder and apply this effect
directly to the filter.

Toolkit – Sharpen +
Once you’ve applied the Controls action above, you can use this action to add some Sharpness to the filter. Open the main filter folder and apply this effect
directly to the filter.

Toolkit – Fix Banding
If you are running into any banding, chances are Photoshop defaulted your project to 8 Bit. Apply this action to update your project to 16 Bit.
 

Reset Group
If you need to start over, apply this action to the main filter folder to reset all its effects.
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You  may  have  already  used  a  filter  or  two  in  Photoshop  (perhaps  as  a  step  in  an  earlier  chapter).  In  this  chapter, filters  are  the  star
players. Depending on which filters you apply and which settings you choose, the results can range from a subtle change to a total morph. You can make
an image look (almost) as if it’s hand painted, silk-screened, or sketched; apply distortion; add a pattern, texture, or noise; create a mosaic or a patchwork
of tiles—the creative possibilities are infinite. Once you start using the Filter Gallery, you’ll see ... time will fly by.

A This is the original image.

B We applied the Charcoal filter.

Applying filters

You can apply filters to a whole layer or just to a selection on a layer. Most of the Photoshop filters are applied either via the Filter Gallery or via an
individual dialog. A small handful of them, such as Clouds and Blur, are applied in one step simply by choosing the filter name from a submenu on the
Filter menu. If you apply a filter to a Smart Object, it becomes an editable, removable Smart Filter.
           If you try to select a filter and discover that it’s not available, the likely cause is that it’s incompatible with the current document color mode or bit
depth. All the Photoshop filters are available for RGB files, most of the filters are available for Grayscale files, fewer are available for CMYK Color, Lab
Color, and 16-bits-per-channel files, still fewer are available for 32-bits-per-channel files, and none are available for Bitmap and Indexed Color files.
Most of the Photoshop filters are housed conveniently under one roof in the Filter Gallery dialog. There you can preview dozens of filters and filter
settings, show and hide each filter effect that you’ve already previewed, and change the sequence in which Photoshop applies them to your document.

To use the Filter Gallery

1. Click an image layer; or for more flexibility, click a duplicate image layer or a Smart Object (see “To apply a Smart Filter” on page 344).

2. Optional: To limit the filter to a specific area of the image, create a selection.

3. The Foreground and/or Background colors are used by many filters  and you must choose those colors now, before opening the Filter Gallery.

4. Choose Filter > Filter Gallery. The resizable gallery opens.
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5. To change the zoom level for the preview, click the Zoom Out button  or Zoom In button in the lower-left corner of the dialog, or choose a
preset zoom level from the menu. (If the preview is magnified, you can drag it in the window.)

6. Do either of the following:

In the middle pane of the dialog, click an arrowhead to expand any of the six filter categories, then click a filter thumbnail.

Choose a filter name from the menu below the Cancel button.

7. On the right side of the dialog, choose settings for the filter.

8. To edit the list of effects (bottom right portion of the dialog), do any of these optional steps:

To apply an additional filter effect, click the New Effect Layer button,  click a filter thumbnail in any category, then choose settings. The effect
may take a moment or two to process.

To replace one filter effect with another, click a filter effect name on the scroll list (don’t click the New Effect Layer button), then choose a
replacement filter and settings.

To hide a filter effect, click the visibility icon  next to the effect name (click again to redisplay).

To change the stacking position of a filter effect to produce a different result in the image, drag the effect name upward or downward on the list.

To remove a filter effect from the list, click it, then click the Delete Effect Layer button.

9. Click OK.
 To hide or show the previews in the Filter Gallery for all but one filter effect, Alt-click/Option-click the visibility icon for that effect.

 To remove a non-Smart Filter, click a prior document state or snapshot on the History panel.

 In Edit/Photoshop > Preferences > Plug-Ins, uncheck Show All Filter Gallery Groups and Names to list, on the submenus on the Filter menu,
only filters that are not in the Filter Gallery, or check this option to list all Photoshop filters on the submenus, including those that are available in
the Filter Gallery (the gallery opens when you choose a filter name).

Filters that Use the Foreground and Background Colors

The filters listed below use the current Foreground and/or Background colors. Some filters, such as Charcoal, Graphic Pen, and Photocopy (in the Sketch
category), look good in the default Photoshop colors of black and white, whereas others look better in color. 

Artistic > Colored Pencil (Background color), Neon Glow (Foreground and Background colors)

 Distort > Diffuse Glow (Background color)

 Pixelate > Point(Background color)

 Render > Clouds, Difference Clouds, Fibers (Foreground and Background colors)

 Sketch > Bas Relief, Chalk & Charcoal, Charcoal, Conté Crayon, Graphic Pen, Halftone Pattern, Note Paper, Photocopy, Plaster, Reticulation,
Stamp, Torn Edges (Foreground and Background colors)

 Stylize > Tiles (Foreground or Background color)

 Texture > Stained Glass (Foreground color)

Reapplying the Last Filter Quickly

 To reapply the last-used filter(s) using the same settings, choose Filter > [last filter name or Filter Gallery] (Ctrl-F/Cmd-F).

 To reopen either the last-used filter dialog or the Filter Gallery showing the last-used settings, press Ctrl-Alt-F/Cmd-Option-F.
Preview Window
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Some Photoshop filters are applied via an individual dialog (not via the Filter Gallery). Of those individual dialogs, some have a preview window and
some do not.

 For individual filter dialogs that contain a preview window, you can click the + button to zoom in or the – button to zoom out (we usually do the
latter). Most of the individual dialogs also have a Preview check box.

 In some filter dialogs (such as Blur > Gaussian Blur and Motion Blur), if you click in the document window (square pointer), that area of the
image will appear in the preview window. You can drag the image inside the preview window.

 To compare the image with and without the current filter effect, click and hold on the preview, then release.
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